Nirn.de

Gast

Thema: Trotz ausreichender Hardware sehr schwache Performance  (Gelesen 2735 mal)

  • Neuling
    • Neuling
Hallo!

Zunächst hier mein System, auf der Seite ist alles genauestens aufgelistet; von Kommentaren à la "Selbst Schuld, wer seinen Rechner bei Aldi kauft" bitte ich abzusehen, sie bringen mich nicht weiter. Nun zum Problem:

Ich spiele Oblivion seit rund eineinhalb Jahren, manchmal mehr, manchmal weniger. Zuletzt wollte ich mich dem Ganzen endlich mal wieder widmen und habe nun auch die Add-Ons installiert, die auf der zweiten CD der GOTY Edition enthalten sind (ich besitze die deutsche GOTY, die bereits in der aktuellen Patch-Version vorliegt). Früher lief Oblivion im Großen und Ganzen gut, es gab aber immerhin auch da schon gelegentliche kurze Performance-Einbrüche, die mich nie allzu sehr gestört haben. Aber schon damals habe ich mich gewundert, denn immerhin ist mein Rechner fünf Jahre neuer als das Spiel und sollte es daher eigentlich packen. Wie auch immer: Da ich länger nicht mehr gespielt habe, weiß ich nicht, ob es mit der Installation der Add-Ons zusammenhängen könnte oder vorher auch schon so gewesen wäre, aber neuerdings ist die Performance völlig im Keller. Ich habe jetzt mal mit dem Befehl "tdt" die FPS-Rate überwacht: In Außenbereichen fängt sie in den 20ern an und pendelt sich dann nach kurzer Zeit irgendwo bei 14 oder noch niedriger ein, es ruckelt merklich. In Innenräumen bleibt die FPS-Rate immerhin meist knapp über 30, geht in Kämpfen aber wiederum runter. Gerade das Durchstreifen der Landschaft macht so einfach keinen Spaß mehr. Ich habe schon an den Grafikeinstellungen rumgedreht, alle Stufen Anti-aliasing ausprobiert, es ganz ausgeschaltet, HDR vs. Bloom usw. Diese Einstellungen machen allenfalls am Anfang dann mal einen Unterschied von einigen FPS, beim Durchstreifen der Landschaft geht die Performance aber schnell wieder arg in den Keller. Selbst die Auflösung habe ich schon runterkorrigiert, das hat etwas mehr gebracht, das Problem aber letztlich auch nicht gelöst. Und ganz ehrlich: Es kann doch auch nicht sein, dass ich alles runterregulieren muss; das Problem muss irgendeine andere Ursache haben.

Ich würde mich freuen, wenn irgendjemand dazu eine Idee hätte! Langsam bin ich mit meinem Latein am Ende. Ich habe noch mal die neuesten Windows-Updates und den aktuellen Nvidia-Treiber installiert und sogar versucht, während des Spielens die Internetverbindung zu trennen, den Echtzeit-Virenscanner abzuschalten usw., aber nichts davon macht einen merklichen Unterschied. Ansonsten laufen keine unnötigen Hintergrundprozesse, die Festplatte wird auch regelmäßig defragmentiert, ich weiß nicht was ich sonst noch machen soll. Ich will doch nur spielen und nicht nebenbei noch Informatik studieren, dafür habe ich gar nicht die Zeit.
« J’ai une âme solitaire »
  11.07.2013, 18:23
  • Offline


  • Skelett
    • Untot
Da gibts dann wohl irgendwelche unpassenden Systemeinstellungen. Schau mal in den Nvidia-Systemeinstellungen und in den allgemeinen Systemeinstellungen und im Bios nach.

Oder das Teil ist beschädigt. Wär vielleicht sowieso nicht schlecht sich was Anderes zu zulegen.  :rolleyes:

Ne GTS 450 ist auch nicht gerade das Neueste.

Wie laufen denn andere Spiele?

Edit:Eigentlich müsste die Hardware mehr als ausreichen, zumindest für mittlere Grafikqualität. Da stimmt dann wohl irgendwas nicht.
« Letzte Änderung: 12.07.2013, 07:00 von Vion »
  12.07.2013, 06:57
  • Offline


  • Schwertkämpfer
    • Kriegergilde
Wir jeden von Vanilla Oblivion GOTY oder? Also ohne irgendwelcher Mods?
Meine Gipfelnebelherrenhausstatistik (mitgespielt ab Runde 4)

Runden mitgespielt: 10,  Runden gewonnen: 5,  Runden verloren: 5,  Runden überlebt: 3,  von den Assassinen ermordet worden: 6,  von der Mehrheit gelyncht worden: 2, als Bürger gewonnen: 3, als Bürger verloren: 4, als Assassine gewonnen: 2, als Assassine verloren: 1
  12.07.2013, 11:31
  • Offline


  • Neuling
    • Neuling
Es ist diese Ausgabe hier: http://www.amazon.de/The-Elder-Scrolls-IV-Oblivion/dp/B004UOWX9I/ref=sr_1_5?ie=UTF8&qid=1373634232&sr=8-5&keywords=oblivion+spiel+des+jahres
Ich habe ganz zu Anfang ein Übersetzungs-Mod installiert, das ein paar der Lokalisierungs-Patzer ausbessert, ansonsten ist es eine weitgehend modfreie Installation.

Sicher, das Neueste ist die Grafikkarte nicht, allgemein auch kein totaler Überflieger, aber sie ist doch immerhin neuer als das Spiel... Andere Spiele laufen ohne Probleme, teils auch aktuellere, wobei ich kaum aktuellere Spiele getestet habe, um ehrlich zu sein. ;) Bei Deus Ex 3 konnte ich aber beispielsweise die Grafikeinstellungen voll ausreizen, ohne nennenswerte Performanceeinbußen hinnehmen zu müssen. Was Anderes anzuschaffen ist erst mal keine Option, allein schon finanziell, zumal der Rechner erst rund zwei Jahre alt ist. Wobei ich immerhin über eine neue Graka nachdenke, falls sich das Ding überhaupt nachrüsten lässt...

Bei den Nvidia-Systemeinstellungen habe ich schon geschaut, es hat mich aber nicht weitergebracht, da ich im Grunde gar nicht weiß, wonach genau ich da eigentlich suche. Vom Bios lasse ich lieber gleich ganz die Finger, mir fehlt da einfach die nötige Sicherheit im Umgang mit diesem Kram. :(
« J’ai une âme solitaire »
  12.07.2013, 15:09
  • Offline


  • Skelett
    • Untot
Andere Spiele laufen ohne Probleme, teils auch aktuellere, wobei ich kaum aktuellere Spiele getestet habe, um ehrlich zu sein. ;) Bei Deus Ex 3 konnte ich aber beispielsweise die Grafikeinstellungen voll ausreizen, ohne nennenswerte Performanceeinbußen hinnehmen zu müssen. Was Anderes anzuschaffen ist erst mal keine Option, allein schon finanziell, zumal der Rechner erst rund zwei Jahre alt ist. Wobei ich immerhin über eine neue Graka nachdenke, falls sich das Ding überhaupt nachrüsten lässt...
Dann muss es an Obli liegen, Deus Ex Human Revolution (oder wie es noch mal heißt  :rolleyes: ) hat viel höhere Anforderungen als Obli. Jedenfalls hats meine GTX 570 ganz schön laut werden lassen.  Installier Obli mal neu.

Vielleicht erst mal Nvidia-Systemsteuerung öffnen, 3D-Einstellungen verwalten, Programm-Einstellungen, da dann Obli auswählen und mal die Einstellungen anschaun.
  12.07.2013, 18:07
  • Offline


  • Neuling
    • Neuling
Genau, ich hätte eben auch gedacht, dass mein Rechner Oblivion locker packen sollte, wenn er mit DX3 keine Probleme hat. Und der Witz ist, früher ging's ja, und das sogar in maximaler Auflösung. Jetzt habe ich sie schon runtergesetzt und es nützt trotzdem nichts. Gerade habe ich mal die Nvidia-Einstellungen zu Oblivion überflogen, konnte aber nichts Ungewöhnliches feststellen (nicht dass ich ein Experte wäre). Probehalber habe ich den Energieverwaltungsmodus mal auf "Maximale Leistung bevorzugen" gestellt und die maximale Einstellung von 4 vorgerenderten Einzelbildern gewählt. Bilde ich mir das ein, oder hatte man früher bei viel mehr Einstellungen die Möglichkeit, einwach "Anwendungsgesteuert" auszuwählen? Wie auch immer: Gibt es sonst besonders "verdächtige" Punkte, auf die ich achten sollte? Mit den o.g. geänderten Einstellungen habe ich es gerade nochmal probiert, wieder draußen, es ging eine Weile in den niedrigen bis mittleren 20ern relativ gut, allerdings war es auch Nacht, daher war die Sichtweite ohnehin begrenzt; nach wenigen Minuten ging die Framerate dann wieder bis auf 12 runter. Über eine Neuinstallation habe ich auch schon nachgedacht, ich zögere nur deshalb, weil ich vorher erst mal die 1-2 installierten Mods wiederfinden müsste und außerdem eine unerklärliche Paranoia habe, dass hinterher meine Savegames nicht mehr funktionieren könnten... Andererseits könnte ich das Übersetzungs-Mod diesmal ganz weglassen und stattdessen gleich alles auf Englisch umstellen - habe mal gelesen, dass das zwar für die Sprachausgabe nicht machbar sei, wohl aber für die geschriebenen Texte (wobei ich das nie überprüft habe). Die deutsche Ausgabe geht mir ohnehin gehörig auf den Nerv... Naja, es wird wohl auf kurz oder lang auf eine Neuinstallation hinauslaufen, zu verlieren habe ich ja letztlich ohnehin nichts, denn so wie es jetzt ist kann ich's eh vergessen. Ob es dann was bringt, bleibt abzuwarten...
« J’ai une âme solitaire »
  12.07.2013, 19:32
  • Offline


  • Schwertkämpfer
    • Kriegergilde
Und wenn du einfach einen neuen Spielstand anfängst? Oblivion hatte glaube ich sonen Bug, der einem irgendwann den Speicher zumüllt, je mehr man im Spiel verändert. Also Gegenstände mitnehmen, woanders hinlegen usw.
Meine Gipfelnebelherrenhausstatistik (mitgespielt ab Runde 4)

Runden mitgespielt: 10,  Runden gewonnen: 5,  Runden verloren: 5,  Runden überlebt: 3,  von den Assassinen ermordet worden: 6,  von der Mehrheit gelyncht worden: 2, als Bürger gewonnen: 3, als Bürger verloren: 4, als Assassine gewonnen: 2, als Assassine verloren: 1
  12.07.2013, 19:38
  • Offline


  • Skelett
    • Untot
Gibt es sonst besonders "verdächtige" Punkte, auf die ich achten sollte?
Vor allem AntiAlias braucht viel Leistung. Falls die AA-Einstellungen auf 2stelligen Werten sind, auf einstellige runter oder auf aus stellen.  :rolleyes: Testweise auch mal Anisotrope Filterung ausschalten, ich glaub aber nicht, dass es daran liegt.

Ich kenn diese Übersetzungsmod nicht, aber schalt sie einfach mal aus. Aber ne Kopie von den Saves machen. Wie viele hast Du eigentlich?

Edit:auch mal die globalen Einstellungen angucken.

http://www.pcwelt.de/ratgeber/Tipps-fuer-die-wichtigsten-3D-Einstellungen-Nvidia-Geforce-Grafikkarte-Ratgeber-210917.html
« Letzte Änderung: 12.07.2013, 22:42 von Vion »
  12.07.2013, 20:09
  • Offline


  • Neuling
    • Neuling
Danke für die Rückmeldungen und sorry für meine verspätete Reaktion. Momentan habe ich wenig bis gar keine Zeit, viel hin- und herzuprobieren, ich hatte ursprünglich gehofft, eine arbeitsreiche Zeit mit gelegentlichen entspannten Oblivion-Sessions ausgleichen zu können... :rolleyes: Sobald ich wieder etwas mehr Luft habe, probiere ich noch mal etwas rum. Am Wochenende hatte ich noch an den Globalen Einstellungen gedreht, viel Relevantes gab es da aber auch nicht mehr, und Antialiasing hatte ich ohnehin auf Anwendungsgesteuert belassen und es hat früher auch keine nennenswerten FPS-Einbußen verursacht. Sicher wäre es ohne schneller gewesen, aber es lief ja weitgehend flüssig. Natürlich habe ich es zuletzt - so wie die meisten potenziell relevanten Einstellungen auch - probehalber mal ein- und ausgeschaltet, aber das brachte allenfalls ein paar FPS Gewinn für die ersten paar Minuten, bevor es wieder in den Keller ging.

Einen neuen Spielstand anzufangen ist erst mal keine Option, da es mir gerade darum geht, meinen bestehenden Charakter weiter zu perfektionieren und damit die noch fehlenden Nebenquests zu erfüllen sowie die Add-Ons zu erkunden. Ich habe keine Lust, wieder als kleiner Nichtsnutz ganz von vorn anzufangen. ;) Savegames habe ich recht viele - über 100. Hat das irgendeinen Einfluss, abgesehen davon, dass es wahnsinnig viel Speicherplatz frisst? Bisher habe ich noch keinen Weg gefunden, die Spielstände direkt aus dem Spielmenü zu löschen (abgesehem von Überschreiben mit einem neuen Spielstand natürlich), was ich aber viel sinnvoller fände, weil ich so vor dem Löschen jeden Spielstand einmal kurz laden könnte, um zu sehen, ob ich ihn noch behalten will. Manche sind eben mehr aus Sicherheitsgründen angelegt worden, während andere dazu da sind, mir im Bedarfsfall die Rückkehr zu einem bestimmten Punkt im Spiel zu ermöglichen. Aber ich habe die Spielstände sowieso noch separat auf einem USB-Stick gesichert und habe nun probehalber einfach mal alle bis auf die aktuellsten und relevantesten aus dem Originalverzeichnis gelöscht. Werde die Tage noch mal schauen wie es sich entwickelt hat.

Ach ja, neuerdings hat das Spiel auch insbesondere beim Reiten merkwürdige Hänger, es geht ein paar Sekunden flüssig und bewegt sich dann immer wieder ruckartig weiter. Im Debugmodus werden in diesen Momenten kurzzeitig erhöhte Werte bei den anderen Kategorien angezeigt, die under der FPS-Rate stehen (keine Ahnung, was die im Einzelnen bedeuten). Sehr eigenartig.
« J’ai une âme solitaire »
  16.07.2013, 16:53
  • Offline


  • Schwertkämpfer
    • Kriegergilde
Das mit dem neuen Spielstand, war ja testweise gemeint. Wenn es mit nem neuen Spielstand ganz normal flüssig läuft, weisst du halt, dass es nicht an irgendwelchen Einstellungen liegt, sondern an diesem ominösen Speichervollauf Bug.

Das hat nicht mit der Anzahl der Spielstände an sich zu tun, sondern liegt daran, dass der Speicher die ganzen Veränderungen, seit Spielbeginn an der Spielwelt vorgenommen wurden, nicht mehr packt. Wenn du irgendwo nen Krug um einen Millimeter verschiebst, muss das Spiel berechnen, das der jetzt nicht mehr da steht, wo er zu Spielbeginn stand, sondern einen Millimeter daneben. Je länger du an deinem Spielstand spielst, und Gegenstände von A nach B transportierst, umso langsamer wird nach und nach alles.
Meine Gipfelnebelherrenhausstatistik (mitgespielt ab Runde 4)

Runden mitgespielt: 10,  Runden gewonnen: 5,  Runden verloren: 5,  Runden überlebt: 3,  von den Assassinen ermordet worden: 6,  von der Mehrheit gelyncht worden: 2, als Bürger gewonnen: 3, als Bürger verloren: 4, als Assassine gewonnen: 2, als Assassine verloren: 1
  16.07.2013, 17:23
  • Offline


  • Neuling
    • Neuling
Die Angabe zur Anzahl meiner Spielstände sowie die diesbezügliche Frage waren an Vion gerichtet, der danach gefragt hatte - hätte ich wohl deutlicher kenntlich machen sollen. ;) Das von dir geschilderte Problem mit dem zugemüllten Speicher hatte ich schon verstanden, trotzdem aber vielen Dank für die Erklärung! Stimmt, probehalber einen neuen Spielstand zu starten ist natürlich eine Option. Gut, ich müsste mich erst mal so weit vorkämpfen, bis ich dann auch wirklich draußen rumrennen kann (denn dort ist das Problem ja am auffälligsten), das sollte sich aber theoretisch machen lassen. Oder ich lade einfach einen ganz frühen Spielstand zu einem Zeitpunkt, an dem ich noch nichts groß geändert habe, das sollte auch schon einen Unterschied machen... Sollte es an diesem Grundproblem des Spiels liegen, nehme ich nicht an, dass es da irgendeinen Workaround gibt, oder? Wenn ich so drüber nachdenke, ist die Theorie jedenfalls nicht abwegig, denn geändert habe ich so einiges, allein schon da ich sämtliche Häuser besitze und dort verschiedenste Truhen/Schreibtische/Kisten vollgemüllt und teilweise auch die Räume umdekoriert habe... :rolleyes: Wobei "vollgemüllt" eigentlich der falsche Ausdruck ist, für mich hat da alles seine Ordnung, aber das Spiel wird das herzlich wenig interessieren.
« J’ai une âme solitaire »
  16.07.2013, 20:06
  • Offline


  • Skelett
    • Untot
Da bleibt dann wohl nur noch ne Neuinstallation wenn Alles andere nicht hilft.
« Letzte Änderung: 17.07.2013, 14:28 von Vion »
  17.07.2013, 14:26
  • Offline


  • Neuling
    • Neuling
Ja, in der Tat. Ich habe jetzt auch langsam aber sicher die Schnauze voll von dem Kack und werde gleich mal alles runterhauen und neu installieren. Ich weiß zwar noch, dass es seinerzeit ein ewiger Krampf war, das Spiel dazu zu bringen, die Tastaturbelegung zu speichern, was ich mir nicht unbedingt nochmals antun will... Aber ich sichere in jedem Fall meine ini-Dateien, vielleicht kann ich die hinterher wiederverwenden.

Dieses Problem ist einfach völlig unvorhersehbar, insofern ist auch keine zielgerichtete Lösungsfindung möglich - mal läuft das Spiel eine ganze Zeitlang relativ solide und mal knickt die Performance schon innerhalb kürzester Zeit so arg ein, dass es völlig unspielbar wird. Also, zwei Alternativen: Entweder die Neuinstallation bringt was, oder das Spiel ist - so leid es mir tut - erst mal gestorben. Dann kann ich es möglicherweise nach dem Kauf einer neuen Graka irgendwann noch mal versuchen. Wie auch immer - ich bin gespannt, was ich hier dann hinterher werde berichten können...
« J’ai une âme solitaire »
  19.07.2013, 20:17
  • Offline


  • Neuling
    • Neuling
Guter Witz: Ich kann das Spiel gar nicht neu installieren, da ich es nicht mal deinstallieren kann. Sobald ich es versuche, erscheint die Fehlermeldung, die falsche Disc sei eingelegt. Probehalber habe ich mal Disc 2 eingelegt, was keinen Unterschied gemacht hat; auch ein Neustart brachte nichts. Ich habe die Deinstallation aus dem Startmenü, dem Oblivion Launcher und der Systemsteuerung versucht, jedes Mal derselbe Mist. Notgedrungen habe ich jetzt, wie im Zuge der Fehlermeldung empfohlen, eine support request an SecuROM geschickt, auch wenn ich bezweifle, dass es was bringen wird. Hoffentlich antworten die wenigstens zeitnah... Toll, wenn durch einen Kopierschutz vor allem die Leute bestraft werden, die sich das Original gekauft haben - was soll ich dazu noch sagen?
« J’ai une âme solitaire »
  19.07.2013, 21:07
  • Offline


  • Skelett
    • Untot
Dann schätz ich mal ist es nicht richtig installiert worden. Versuch mal Ccleaner.

Kenn mich nicht wirklich damit aus, aber vielleicht hilft es, die ganzen Obli-Ordner manuell zu löschen und in der Registry den Obli-Eintrag zu löschen:

HKEY_LOCAL_MACHINE\SOFTWARE\Bethesda Softworks\Oblivion

Wenn von Beth nicht noch was installiert ist, dann kannst Du auch den ganzen "Bethesda Softworks" Ordner löschen. Und neu starten.

Am Ende der Neuinstallation ist ein Fenster geöffnet wo nix drin steht und vermuten lässt, die Installation sei abgeschlossen. Das ist sie aber erst, wenn dieses leere Fenster verschwunden ist. So ganz genau weiß ich das nicht mehr, aber bei der Neuinstallation abwarten, bis dort ausdrücklich steht, dass es fertig installiert wurde.
« Letzte Änderung: 20.07.2013, 15:19 von Vion »
  20.07.2013, 15:16
  • Offline


  • Bettler
    • Neuling
Ne Komplett Defragmentieren durchführen.
Würde auch mal vorschlagen win neu zu installieren wenn gar nichts geht.
und bitte im virtuellen Speicher Max und Minimum das selbe eintragen. :-)
den muss er nicht den virtuellen Speicher per Langsamer HD Vergrössern sondern ist bei der Maximalen Grösse.
Hab 8 GB Speicher und 10GB virtuellen Speicher.

Wegen Aldi, ich baue den PC immer selber zusammen und seit 9 Jahren im selben Rollenden Server Bigtower, bin immer schneller als jeder 3-4 jahre neueren Komplett PCs.

  21.07.2013, 17:37
  • Offline


  • Graf
    • Adel
Wenn ich nur durchs Internet würgen könnte...

Wie kann man bei jedem kleinen Problem gleich vorschlagen, Windows neu zu installieren? Wie geht das?
Das ist ein sicheres Zeichen für völligen Dilettantismus. Windows neu zu installieren schlägt man vor, wenn alles andere gescheitert ist. Niemals vorher, es sei denn, man möchte sich als Dummschwätzer outen, der es nur auf viele Posts abgesehen hat.

Eine Defragmentierung ist nie verkehrt, aber da andere Spiele problemlos laufen vermutlich nicht akut notwendig.
8GB RAM+10 GB V-Speicher? 18GB? Was willst du damit machen? Filme schneiden? Physikalische CAD-Simulationen? Homeoffice bei der NASA? Kein Otto-Normal-Program und kein Spiel der Welt lastet 8GB aus. Eigentlich bräuchte man bei dem RAM garkeinenen virtuellen Speicher, nur gibt es Programme, die den unbedingt nutzen wollen. Für die reicht es, den virtuellen Speicher auf ein paar hundert MB festzulegen. Bei 4GB RAM eigentlich auch, da würde ich maximal 1 GB V-Speicher geben. Wenn man den V-Speicher manuell festlegt, sollte man allerdings in der Tat beide Größen auf den gleichen Wert festlegen, damit eine Fragmentierung des V-Speichers vermieden wird.
Und dein letzter Halbsatz ergibt keinen Sinn.
  22.07.2013, 08:10
  • Offline
  • SCP-Wiki-DE


  • Agent
    • Klingen
Um solche Posts zu würdigen (wie den von Grom), fordere ich hiermit (wieder einmal), dass der "Danke"-Button eingeführt wird.
Da es ihn noch nicht gibt, führe ich meine Lobpreisung manuell durch: Danke, Grom!  :ugly:

Pro Einhorn? Ich bin dabei!

Diese Steam Signatures sind echt cool... :)
  22.07.2013, 13:26
  • Offline